Нужна помощь с тестовой проблемой Python
For example, you get a 8x8 picture: 000##000 0##0#000 ###0#### 0#0##### #0#0#000 #0##0000 0###0000 00#00000 Now you gotta find the "target" which is a 3x3: 0#0 ### 0#0 Every-time the target appears you add one to count, in this case count would be 3 Sample input: 000##000 0##0#000 ###0#### 0#0##### #0#0#000 #0##0000 0###0000 00#00000 0#0 ### 0#0 Sample Output: 3
Что я уже пробовал:
Я сделал входную часть, так что добавьте к ней или измените ее, если хотите:
import sys import math m=[] a=[] for i in range(8): l=sys.stdin.readline() m.append(l[:-1]) for i in range(3): c=sys.stdin.readline() a.append(c[:-1])